SteveDickinson
Printers
Post type: post

Printers

This blog is place for me to dump information about Printers. Over the years I have used a variety of printers. Initially (1995 – 2000) Epson was my manufacturer of choice, predominantly because of quality of print. For a short period I dallied with HP, because the convenience, but the quality of both their printers and print was not that good. More recently I have favoured Canon. Predominantly because of print quality, (I undertake a lot of Photographic printing) but the printers themselves are good quality and very reasonably priced.

All printers I have used for photographic work have been inkjet. I have had laser printers, but these were mono and used for business documents and correspondance. The quality of the the laser printers for text was way better than inkjet and faster print runs, but once my business model changed so that I was producing fewer reports I could not justify the cost .

When I say I could not justify the cost, the problem was the cost of the laser printers themselves. I was never at the top end, and I found at the level I was purchasing the feed mechanisms would wear out. The cost of replacing the feed mechanism was of the same order of cost as buying a new printer, which meant replacing the printer every four to five years.

That said, this was back in the early 2000’s so maybe things are different now.

However back to today. As I mentioned, for me now, Canon is the manufacturer of choice. I have two printers:

  • PIMXA MG5650
  • PIXMA Pro 100S

Pixma MG5650
Pixma MG5650
PIXMA Pro 100S
PIXMA Pro 100S

The MG5650 is the work-horse, text documents, scanning, and some photographic work – it does have individual cartridges for Cyan, Mageneta and Yellow, and produces acceptable images, but for my main photographic prints I use the Pro 100S. Supberb images upto A3 and at an acceptable throughput, once you have got past the startup time – which is annoyingly slow. (Canon claims a A3 image print takes 90 secs. I haven’t timed it, but that seems about right).

Loading Photographic paper in the rear feed is a little tricky, the paper has to be seated correctly in the guides, which you might think is obvious, but unfortuately, it is way too easy to sit the paper behind the guides, in which case it will not feed. And as an FYI, photographic paper is loaded print side up.

Canon Cartidges

As I said I like Canon’s print quality, and part of that quality is, obviously, down to their inks. However their cartidges are hordenously expensive. This year I did bite the bullet and tried the LCL equivalent cartidges both in the Pixma MG5650 (551’s) and Pixma Pro 100S (42’s).

So far, no problems. The cartidges have functioned perfectly, quality looks just as good, and they are at least a 1/3rd the price. Don’t get me wrong, I would prefer to stick with Canon, if only for the confidence of knowing that, should there be a problem, then I have a better chance of getting a resolution. However the price of the Canon cartidges is just too high. At full set of cartidges for the Pro 100S is basically £90. OK there are eight, but even so that, as an on going expence, is too high.

Another computer is using the printer

This is an error message that I have been getting with irritating regularity. I try to print from my Windows PC to my Canon printer and whilst it returns the status of the printer and ink cartidges, it refuses to print because it believes the printer is in use by another computer.

I searched the web to try to find a solution, and it appears that the problem has been around for some time. Since at least 2014. Microsoft say the problem is with Canon, and their usual suggestion is to reload the printer driver. Canon say the problem is with Windows, and their usual suggestion is to reboot the PC. Another suggestion, from a User with the problem, is to power off the printer at the socket, and then switch back on.

I finally came across the real culprit (at least for me it is), and that is the Print Spooler. To fix the problem on Windows 10. Type Control Panel in the windows search box and select the App. Go to:

Control Panel>System and Security>Administrative Tools>Services.

Scroll down to Print Spooler and stop and start this service.

Works for me every time.